Jump to content
DOSBODS
  • Welcome to DOSBODS

     

    DOSBODS is free of any advertising.

    Ads are annoying, and - increasingly - advertising companies limit free speech online. DOSBODS Forums are completely free to use. Please create a free account to be able to access all the features of the DOSBODS community. It only takes 20 seconds!

     

  • 0

VPNs and Windows 10


DTMark
 Share

Question

I need to remain connected to a VPN all day so as to have a fixed IP address.

This was configured in Windows and worked fine. Until one day, when it didn't. It wouldn't connect.

The VPN provider recommended I download "Open VPN" which is a connection tool. That worked fine. Until it didn't.

One of two things happens:

1. It remains connected but there's nothing there - no connectivity, no DNS, until I manually click "Reconnect", or

2. It periodically elects to reconnect by itself which I may or may not notice. And sometimes it succeeds, sometimes it does not. Log file shows an entry like: Mon Apr 12 13:28:04 2021 [vpnuk-openvpn-server-2019] Inactivity timeout (--ping-restart), restarting

So I've gone from a working setup to one that breaks about every 5 to 20 minutes.

Windows won't connect at all (it cycles between "Connecting".. and "Verifying your sign in info") . Open VPN doesn't remain connected.

I can reproduce this behaviour on another computer here with the same setup which developed the identical problem with the Windows VPN connection around the same time and which behaves identically with the Open VPN tool.

I don't know whether the problem is with the VPN provider, both the Windows computers *, or if it's something the router is doing that's breaking it.

How can I diagnose and check this?

* My desktop has Windows Update enabled. The other computer is my laptop from which I removed Windows Update entirely long before this started, so it hasn't updated itself.

Edited by DTMark
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0
6 hours ago, DTMark said:

vpnuk-openvpn-server-2019] Inactivity timeout (--ping-restart), restarting

Just try entering the log message in a browser.  Loads out there like:

https://www.sparklabs.com/support/kb/article/error-inactivity-timeout-ping-restart/

Has your VPN supplier got its own windows app to use (which in turns uses OpenVPN)?  You'll probably do better with that than using Windows alone.  And have you read the forum for your VPN provider?  You're unlikely to be the first, although I was with IPv6 issues with OpenVPN.

PS:  A VPN does not normally guarantee a fixed IP address.  The VPN provider is in control of the connection and the hoster may change for load balancing, etc.  I get changes furing the day.  Another reason VPN app helps as it can lock the connection (ie. terminate the session if VPN is lost and you go clear). 

Edited by Harley
Link to comment
Share on other sites

  • 0

The VPN does have a fixed IP in this case - it's less about privacy and all about keeping the same IP. Actually, I don't know whether the underlying fibre connection has a fixed IP, I have never thought to check. I just assume it does not. It would simplify things..

Where this is, is that Windows cannot connect to the VPN using any of the connection protocols. They all fail. Yet, this used to work. Why this has changed is a mystery. It's not the internet connection nor the fibre modem since it's the same if I tether the PC to my mobile and go out via 4G. It's not a Windows Update since my laptop stopped working at the same time and that doesn't have Windows Update on it. I worked out how to completely kill that, so the version of Windows must be 4 years old now.

So I am using the VPN provider's preconfigured OpenVPN software. What happens is that periodically the connection fails. It doesn't drop. There's just nothing there. No connectivity, no DNS. If I click Reconnect it usually comes back. But not always. Sometimes it gets stuck logging in. I am tempted to believe that is the auth server at their end being overloaded occasionally.

The effect of this is that in a Teams meeting, the connection will just die periodically and I'll lose connection to the meeting.

If I connect to Teams without the VPN it's fine. However I might be demonstrating something with screen sharing. That requires the VPN is on, since that is part of the authentication to the web and SQL Server for the thing that I am demonstrating.

In all honesty I might just set up my own VPN on a "budget box" and be done with it. That's only about £17 a month versus £10 a month for a flaky service from the VPN provider and there will probably be more bandwidth on tap - the glorious 950Mbps down and 125Mbps up from the underlying connection is hobbled to more like 80/80 via the VPN provider.

 

Link to comment
Share on other sites

  • 0

Right then..

I've set up my own VPN which worked on my mobile just fine. Still wouldn't work on Windows 10.

Actually, the problem was a Windows Update on this machine which broke VPNs, from 10 April - KB5000808 - which needs to be removed for Windows to connect to VPNs.

And having done that I now have my own private VPN which runs at around 100Mbps both up and down, which isn't too shabby.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...